Rezultate 1 la 10 din 10

Subiect: Probleme cu procesorul si consumul de memorie.

  1. #1
    Avatarul lui Netul
    Netul este deconectat Ambasador
    Data înscrierii
    5th January 2006
    Locaţie
    Iasi
    Vârstă
    35
    Posturi
    1.052
    Putere Rep
    27


    Implicit Probleme cu procesorul si consumul de memorie.

    Buna ziua. Am un subdomeniu gazduit pe un calculator propriu ce tine o baza de date destul de mare (2 GB) si nu stiu daca e normal sa imi manance atat de mult din proceros atunci cand cineva cauta in baza de date. Cautarea in baza de date se face in 1-2 secunde insa procesorul sta la 100% timp de 10-20 secunde (sau chiar mai mult). Procesele ce consuma resursele procesorului sunt mysql si apache (nu amndoua simultan, intai sta mysql la 100%, dupa care scate mult, imediat urca apache la 100% , asta in timp ce cineva cauta in baza de date). Folosesc Vista (mda, nu imi dati in cap, si nu incepeti cu sfaturi gen: treci pe linux, o sa fac si asta). Ma gandesc ca problema apare si pt ca am alocat f multe resurse pt mysql, astfel:

    skip-locking
    key_buffer = 64M
    max_allowed_packet = 16M
    table_cache = 512
    sort_buffer_size = 1M
    read_buffer_size = 256K
    read_rnd_buffer_size = 256K
    net_buffer_length = 16K
    thread_stack = 128K
    myisam_sort_buffer_size=32M
    join_buffer=2M
    record_buffer=2M
    sort_buffer=4M
    thread_cache_size=512
    tmp_table_size = 32M

    [mysqld_safe]
    open_files_limit = 8192

    [mysqldump]
    quick
    max_allowed_packet=10M

    [mysqlcheck]
    key_buffer=64M
    sort_buffer=64M
    read_buffer=32M
    write_buffer=32M

    [mysql]
    no-auto-rehash
    # Remove the next comment character if you are not familiar with SQL
    #safe-updates

    [isamchk]
    key_buffer = 4M
    sort_buffer_size = 4M

    [myisamchk]
    key_buffer=64M
    sort_buffer=64M
    read_buffer=16M
    write_buffer=16M

    [mysqlhotcopy]
    interactive-timeout

    Deci problema e ca, atunci cand cauta cineva in baza de date, chiar daca lui ii returneaza instantaneu rezultatele, mie imi ramane procesorul la 100% mult timp.
    Atasez si o poza din Performance (Task Manager), se vede cum sta procesorul la 100 f mult si f des.

    Aveti o solutie sau sfaturi?
    Va multumesc.
    Imagini atașate Imagini atașate
    Am un Forum de Discutii generalist si ofer servicii de publicitate.

  2. #2
    Avatarul lui Toto
    Toto este deconectat Super Moderator
    Data înscrierii
    14th June 2005
    Locaţie
    Bucuresti
    Posturi
    1.904
    Putere Rep
    26


    Implicit

    1 - reproiecteaza motorul de cautare si implicit baza de date in care se executa cautarea
    2 - muta motorul de cautare pe un server dedicat

    Este normal sa iti manance multe resurse mai intai mysql care executa cautarea si apoi apache-ul care scuipa rezultatele...

    Faptul ca iti ramane procul sus si dupa cautare mult timp, este din cauza ca win-ul are o gestionare a resurselor foarte proasta...

    O solutie, nu stiu cate de buna, ar fi un proc mai mare (cel mai mare) + ram mai mult (cel mai mult) + un HDD cu viteza de citire mare (cea mai mare), eventual SCSI... Dar nu cred ca asta e calea cea buna...

    Bafta!

    PS - oftopic
    Semnaturile tale nu respecta Regulamentul Seopedia. Te rugam sa recitesti regulametul si sa modifici conform celor scrise acolo. Multumim.
    Ultima modificare făcută de Toto; 8th June 2007 la 01:20.

  3. #3
    Avatarul lui tis
    tis
    tis este deconectat Membru SeoPedia
    Data înscrierii
    9th October 2006
    Locaţie
    Cluj
    Vârstă
    31
    Posturi
    251
    Putere Rep
    14


    Implicit

    Incearca asa:
    Cod:
    skip-locking
    # asta doar daca nu folosesti innodb
    skip-innodb
    
    # asta trebuie pus cam la un sfert din RAM
    key_buffer = 256M
    max_allowed_packet = 16M
    table_cache = 512
    sort_buffer_size = 1M
    read_buffer_size = 256K
    read_rnd_buffer_size = 256K
    net_buffer_length = 16K
    thread_stack = 128K
    myisam_sort_buffer_size=32M
    join_buffer=2M
    record_buffer=2M
    sort_buffer=4M
    thread_cache_size=512
    tmp_table_size = 32M
    
    # Pune tipul cache-ului 1 si pune niste limite
    # Limita pentru fiecare query pastrat in cache e de 1M
    # Cache-ul e de tip 1 - adica se pune in cache tot ce se poate
    # Cache-ul total pentru query-uri e de 32M
    query_cache_limit = 1M
    query_cache_type = 1
    query_cache_size = 32M
    Nu am incercat pe windows niciodata dar poate te ajuta. Uita-te aici: http://www.apacheref.com/ref/http_core/RLimitMEM.html
    Si aici: http://www.apacheref.com/ref/http_core/RLimitCPU.html

    Iti recomand RLimitMEM 50 100 si RLimitCPU 30 60.

    Anyway, cea mai buna solutie deja ti-ai dat-o singur: hosting pe Linux sau, daca se poate, un FreeBSD ca e mai rapid.

  4. #4
    Avatarul lui Netul
    Netul este deconectat Ambasador
    Data înscrierii
    5th January 2006
    Locaţie
    Iasi
    Vârstă
    35
    Posturi
    1.052
    Putere Rep
    27


    Implicit

    E jale acum, procesorul sta la 100% non stop. Folosesc xampp. Am scos si cablul de retea din calc, si tot la 100% ramane. Am dar si restart la apache si mysql dar imediat ce le redeschid, procesorul se dulce la 100% si ramane asa (procesul ce consuma procesorul e mysql).
    Calculatorul e destul de bun, Athlon 64 la 3500+, si inainte nu aveam problemele astea.

    PS: tis, nu am incercat ce ai zis tu, incerc maine dimineata, sper sa aiba efect.
    Am un Forum de Discutii generalist si ofer servicii de publicitate.

  5. #5
    Avatarul lui Netul
    Netul este deconectat Ambasador
    Data înscrierii
    5th January 2006
    Locaţie
    Iasi
    Vârstă
    35
    Posturi
    1.052
    Putere Rep
    27


    Implicit

    Am pus asa cum ai zis, dar tot la 100% ramane

    RLimitMEM 50 100
    RLimitCPU 30 60

    astea trebuie puse in httpd.cnf banuiesc.
    Tot degeaba.
    Am un Forum de Discutii generalist si ofer servicii de publicitate.

  6. #6
    Avatarul lui tis
    tis
    tis este deconectat Membru SeoPedia
    Data înscrierii
    9th October 2006
    Locaţie
    Cluj
    Vârstă
    31
    Posturi
    251
    Putere Rep
    14


    Implicit

    Da, in httpd.conf trebuie puse.

    Te-ai uitat in logurile de la apache ? Nu cumva e vreun (D)DoS ?

    Daca nu e DoS, singura explicatie ar fi ca Vista are o management al resurselor mai prost decat XP/2000/2003. Pune-ti un Windows2003 daca vrei sa ramai pe Microsoft sau un FreeBSD si nu ar trebui sa mai ai probleme de genul asta.

  7. #7
    Avatarul lui inscaun
    inscaun este deconectat Membru SeoPedia
    Data înscrierii
    30th March 2007
    Locaţie
    Bucharest
    Vârstă
    30
    Posturi
    777
    Putere Rep
    16


    Implicit

    tis nu are nici o legatura cu httpd.conf
    aici e vorba de configu de la mysql, nu de la apache, credeam ca daca ai postat stiai despre ce vb...

    modifica in my.cnf


    # Example MySQL config file for medium systems.
    #
    # This is for a system with little memory (32M - 64M) where MySQL plays
    # an important part, or systems up to 128M where MySQL is used together with
    # other programs (such as a web server)
    #
    # You can copy this file to
    # /etc/my.cnf to set global options,
    # mysql-data-dir/my.cnf to set server-specific options (in this
    # installation this directory is /var/lib/mysql) or
    # ~/.my.cnf to set user-specific options.
    #
    # In this file, you can use all long options that a program supports.
    # If you want to know which options a program supports, run the program
    # with the "--help" option.

    # The following options will be passed to all MySQL clients
    [client]
    #password = your_password
    port = 3306
    socket = /var/run/mysql/mysql.sock

    # Here follows entries for some specific programs

    # The MySQL server
    [mysqld]
    port = 3306
    socket = /var/run/mysql/mysql.sock
    skip-locking
    key_buffer = 16M
    max_allowed_packet = 1M
    table_cache = 64
    sort_buffer_size = 512K
    net_buffer_length = 8K
    read_buffer_size = 256K
    read_rnd_buffer_size = 512K
    myisam_sort_buffer_size = 8M

    # Don't listen on a TCP/IP port at all. This can be a security enhancement,
    # if all processes that need to connect to mysqld run on the same host.
    # All interaction with mysqld must be made via Unix sockets or named pipes.
    # Note that using this option without enabling named pipes on Windows
    # (via the "enable-named-pipe" option) will render mysqld useless!
    #
    #skip-networking

    # Replication Master Server (default)
    # binary logging is required for replication
    log-bin=mysql-bin

    # required unique id between 1 and 2^32 - 1
    # defaults to 1 if master-host is not set
    # but will not function as a master if omitted
    server-id = 1

    # Replication Slave (comment out master section to use this)
    #
    # To configure this host as a replication slave, you can choose between
    # two methods :
    #
    # 1) Use the CHANGE MASTER TO command (fully described in our manual) -
    # the syntax is:
    #
    # CHANGE MASTER TO MASTER_HOST=<host>, MASTER_PORT=<port>,
    # MASTER_USER=<user>, MASTER_PASSWORD=<password> ;
    #
    # where you replace <host>, <user>, <password> by quoted strings and
    # <port> by the master's port number (3306 by default).
    #
    # Example:
    #
    # CHANGE MASTER TO MASTER_HOST='125.564.12.1', MASTER_PORT=3306,
    # MASTER_USER='joe', MASTER_PASSWORD='secret';
    #
    # OR
    #
    # 2) Set the variables below. However, in case you choose this method, then
    # start replication for the first time (even unsuccessfully, for example
    # if you mistyped the password in master-password and the slave fails to
    # connect), the slave will create a master.info file, and any later
    # change in this file to the variables' values below will be ignored and
    # overridden by the content of the master.info file, unless you shutdown
    # the slave server, delete master.info and restart the slaver server.
    # For that reason, you may want to leave the lines below untouched
    # (commented) and instead use CHANGE MASTER TO (see above)
    #
    # required unique id between 2 and 2^32 - 1
    # (and different from the master)
    # defaults to 2 if master-host is set
    # but will not function as a slave if omitted
    #server-id = 2
    #
    # The replication master for this slave - required
    #master-host = <hostname>
    #
    # The username the slave will use for authentication when connecting
    # to the master - required
    #master-user = <username>
    #
    # The password the slave will authenticate with when connecting to
    # the master - required
    #master-password = <password>
    #
    # The port the master is listening on.
    # optional - defaults to 3306
    #master-port = <port>
    #
    # binary logging - not required for slaves, but recommended
    #log-bin=mysql-bin

    # Point the following paths to different dedicated disks
    #tmpdir = /tmp/
    #log-update = /path-to-dedicated-directory/hostname

    # Uncomment the following if you are using BDB tables
    #bdb_cache_size = 4M
    #bdb_max_lock = 10000

    # Uncomment the following if you are using InnoDB tables
    #innodb_data_home_dir = /var/lib/mysql/
    #innodb_data_file_path = ibdata1:10M:autoextend
    #innodb_log_group_home_dir = /var/lib/mysql/
    #innodb_log_arch_dir = /var/lib/mysql/
    # You can set .._buffer_pool_size up to 50 - 80 %
    # of RAM but beware of setting memory usage too high
    #innodb_buffer_pool_size = 16M
    #innodb_additional_mem_pool_size = 2M
    # Set .._log_file_size to 25 % of buffer pool size
    #innodb_log_file_size = 5M
    #innodb_log_buffer_size = 8M
    #innodb_flush_log_at_trx_commit = 1
    #innodb_lock_wait_timeout = 50

    [mysqldump]
    quick
    max_allowed_packet = 16M

    [mysql]
    no-auto-rehash
    # Remove the next comment character if you are not familiar with SQL
    #safe-updates

    [isamchk]
    key_buffer = 20M
    sort_buffer_size = 20M
    read_buffer = 2M
    write_buffer = 2M

    [myisamchk]
    key_buffer = 20M
    sort_buffer_size = 20M
    read_buffer = 2M
    write_buffer = 2M

    [mysqlhotcopy]
    interactive-timeout
    Ultima modificare făcută de inscaun; 12th June 2007 la 17:34.

  8. #8
    Avatarul lui tis
    tis
    tis este deconectat Membru SeoPedia
    Data înscrierii
    9th October 2006
    Locaţie
    Cluj
    Vârstă
    31
    Posturi
    251
    Putere Rep
    14


    Implicit

    Citat Postat în original de inscaun Vezi Post
    tis nu are nici o legatura cu httpd.conf
    aici e vorba de configu de la mysql, nu de la apache, credeam ca daca ai postat stiai despre ce vb...
    Daca am postat stiam despre ce vb...

    Tu ai citit ce a postat Netul ? primul post. Eu l-am citit si am vazut ca dupa ce se apuca mysqld si consuma resurse incepe si apache sa consume multe. Poate nu stau bine cu logica, dar cred ca alea doua au ceva legatura mai ales daca e vorba de un server web care cere date de la mysql si apoi le prelucreaza. Tu ce crezi ?

  9. #9
    Avatarul lui inscaun
    inscaun este deconectat Membru SeoPedia
    Data înscrierii
    30th March 2007
    Locaţie
    Bucharest
    Vârstă
    30
    Posturi
    777
    Putere Rep
    16


    Implicit

    numai cred nimik.. sunt 100% sigur ca este de la query-urile mysql ...
    sfatu meu e sa faca un debuging, si sa se uite in logurile de la mysql care face pe nebunu acolo..
    si sa faca o optimizare la selectare date dupa anumiti indexsi
    mai multe aici
    http://dev.mysql.com/doc/refman/5.0/...ate-index.html
    http://dev.mysql.com/doc/refman/5.0/...l-indexes.html

    dar asta o poti face mai usor cu clientu de mysql...

  10. #10
    Avatarul lui agnus
    agnus este deconectat Membru SeoPedia
    Data înscrierii
    15th June 2007
    Vârstă
    33
    Posturi
    35
    Putere Rep
    13


    Implicit

    problema poate fi de la modul in care sunt construite sql-urile in scriptul php. La o baza de date de dimensiunile celei specificate, nu prea te joci cu union sau joinuri pentru ca merge fff greu.
    Seteaza index pe coloanele din tabelel mysql si utilizeaza limit in cazul in care nu o faci deja.

    Succes
    may the best of your past be the worst of your future

Informații subiect

Utilizatori care navighează în acest subiect

Momentan este/sunt 1 utilizator(i) care navighează în acest subiect. (0 membrii și 1 vizitatori)

Thread-uri Similare

  1. probleme cu indexarea
    De psaico în forumul Continut web
    Răspunsuri: 10
    Ultimul Post: 27th May 2009, 13:47
  2. probleme site
    De cristi-net în forumul Dezbateri SEM
    Răspunsuri: 4
    Ultimul Post: 27th May 2009, 13:13
  3. Probleme indexare
    De doxxx în forumul Website-uri
    Răspunsuri: 3
    Ultimul Post: 27th May 2009, 12:02
  4. Probleme la GTS?
    De pustiu în forumul Bar, lobby...
    Răspunsuri: 8
    Ultimul Post: 29th November 2006, 18:11

Permisiuni postare

  • Nu puteţi posta subiecte noi.
  • Nu puteţi răspunde la subiecte
  • Nu puteţi adăuga ataşamente
  • Nu puteţi modifica posturile proprii
  •