Salut,

Urmeaza ca Wordpress sa actualizeze versiunea minima de PHP:
- din Aprilie 2019, PHP 5.6;
- din Decembrie 2019, PHP 7 devine obligatoriu pentru noile versiuni de Wordpress.

Versiunile vechi de Wordpress vor primi update-uri de securitate, dar nu se va putea trece la alta versiune de WP fara a avea versiunea minima de PHP.

Upgrade-ul la PHP 7.x este un salt foarte mare pentu programarea web, iar scripturile PHP trebuiesc verificate dupa upgrade. Este posibil ca unele scripturi sa nu mai functioneze corect pe noua versiune PHP.

Cu cat incepi mai repede trecerea la PHP 7, cu atat mai bine.

Post oficial: https://make.wordpress.org/core/2018...m-php-version/
Beneficiile PHP 7: https://visualmodo.com/the-benefits-of-php-7/