Rezultate 1 la 9 din 9

Subiect: de ce nu se instaleaza ultima versiune de PHP?

  1. #1
    Avatarul lui Rapsodia
    Rapsodia este deconectat Membru SeoPedia
    Reputatie:
    24
    Data înscrierii
    18th March 2013
    Locaţie
    Hungary + Chișinău + Câmpina
    Posturi
    2.604
    Putere Rep
    24


    Implicit de ce nu se instaleaza ultima versiune de PHP?

    Se dau 4 site-uri, 2 pe un host si 2 pe altul. mamica.org si klumea.info pe 1 si i4jobs.net si broderii.info pe al 2-lea. Pe primul nu se face update la PHP de la 7.2 la 7.4, pe al doilea fara probleme. Ultima versiune de WP si aceleasi plugins, aceleasi teme cumparate. Nu-i dau de cap, ma poate ajuta cineva?
    Ofer servicii Social Media Marketing!. Articole contra cost Oferta generala, ro, fr si ru aici!

  2. #2
    Avatarul lui gabetu
    gabetu este deconectat Membru SeoPedia
    Reputatie:
    20
    Data înscrierii
    10th April 2011
    Locaţie
    Piatra Neamt
    Posturi
    175
    Putere Rep
    20


    1 out of 1 members found this post helpful.

    Implicit

    In ce sens nu se "instaleaza" ?
    Versiunea de php se seteaza din CPanel -> MultiPHP Manager: https://ibb.co/10yqHG1
    Ceea ce adauga urmatorul cod in .htaccess:
    # php -- BEGIN cPanel-generated handler, do not edit
    # Set the “ea-php74” package as the default “PHP” programming language.
    <IfModule mime_module>
    AddHandler application/x-httpd-ea-php74 .php .php7 .phtml
    </IfModule>
    # php -- END cPanel-generated handler, do not edit
    Daca nu functioneaza inseamna ca serverul nu suporta v.7.4 desi ar trebui ca s-a ajuns deja la v.8.0.6

  3. #3
    Avatarul lui Rapsodia
    Rapsodia este deconectat Membru SeoPedia
    Reputatie:
    24
    Data înscrierii
    18th March 2013
    Locaţie
    Hungary + Chișinău + Câmpina
    Posturi
    2.604
    Putere Rep
    24


    Implicit

    Citat Postat în original de gabetu Vezi Post
    In ce sens nu se "instaleaza" ?
    Versiunea de php se seteaza din CPanel -> MultiPHP Manager: https://ibb.co/10yqHG1
    Ceea ce adauga urmatorul cod in .htaccess:


    Daca nu functioneaza inseamna ca serverul nu suporta v.7.4 desi ar trebui ca s-a ajuns deja la v.8.0.6
    Pai cum sa dovedesc celor de la hosting ca nu suporta 7.4 daca el este in lista lor de versiuni, doar ca dupa instalare nu mai merge site-ul.
    Ofer servicii Social Media Marketing!. Articole contra cost Oferta generala, ro, fr si ru aici!

  4. #4
    Avatarul lui gabetu
    gabetu este deconectat Membru SeoPedia
    Reputatie:
    20
    Data înscrierii
    10th April 2011
    Locaţie
    Piatra Neamt
    Posturi
    175
    Putere Rep
    20


    Implicit

    Vezi daca s-a adaugat codul de mai sus in .htaccess

    Am intrat pe fiecare site din cele 4 si merg numai ca primesc notificare ca ssl-ul nu functioneaza corect pe homepage-uri ?

  5. #5
    Avatarul lui Rapsodia
    Rapsodia este deconectat Membru SeoPedia
    Reputatie:
    24
    Data înscrierii
    18th March 2013
    Locaţie
    Hungary + Chișinău + Câmpina
    Posturi
    2.604
    Putere Rep
    24


    Implicit

    Am asa

    # php -- BEGIN cPanel-generated handler, do not edit
    # Set the “alt-php74” package as the default “PHP” programming language.
    <IfModule mime_module>
    AddHandler application/x-httpd-alt-php74 .php .php7 .phtml
    </IfModule>
    # php -- END cPanel-generated handler, do not edit
    eroarea e Your PHP installation appears to be missing the MySQL extension which is required by WordPress.

    sincer nu pricep ce difera fata de restul site-urilor, la toate e aceiasi tema, acelasi WP automat Update, etc.

    Vad ca a mers macar 7.3, dar 7.4 si 8.0 nu merg

    Ca idee WP asa zice:

    PHP modules perform most of the tasks on the server that make your site run. Any changes to these must be made by your server administrator. Adica nu de mine, dar cei de la hosting zic ca eu ceva nu am facut ok.

    Am facut si redirectul ok cu ocazia asta, ca imi scapase
    Ultima modificare făcută de Rapsodia; 4th June 2021 la 20:06.
    Ofer servicii Social Media Marketing!. Articole contra cost Oferta generala, ro, fr si ru aici!

  6. #6
    Avatarul lui kleampa
    kleampa este conectat acum Ambasador
    Reputatie:
    45
    Data înscrierii
    31st May 2006
    Locaţie
    Bucuresti
    Vârstă
    32
    Posturi
    1.531
    Putere Rep
    45


    Implicit

    daca e vreo versiune prea veche de wordpress se poate intampla.
    de la nu stiu ce versiune incoace au scos folosirea extensiei mysql (pt ca nu mai era suportata de versiunile noi de php) si au trecut pe mysqli

    eventual poti face un fisier cu phpinfo() si vezi ce extensie de mysql e folosita. nu mai stiu prin cpanel daca poti activa de capul tau diverse extensii ca sa poti rezolva
    Ești bun/ă la SEO? Vezi joburi disponibile.

  7. #7
    Avatarul lui Rapsodia
    Rapsodia este deconectat Membru SeoPedia
    Reputatie:
    24
    Data înscrierii
    18th March 2013
    Locaţie
    Hungary + Chișinău + Câmpina
    Posturi
    2.604
    Putere Rep
    24


    Implicit

    Citat Postat în original de kleampa Vezi Post
    daca e vreo versiune prea veche de wordpress se poate intampla.

    nu mai stiu prin cpanel daca poti activa de capul tau diverse extensii ca sa poti rezolva
    Versiunea WP e ultima: 5.7.2, asta le zic si eu celor de la hosting, ca problema e la ei, ei nu si nu ca eu ar trebui sa rezolv.
    Ofer servicii Social Media Marketing!. Articole contra cost Oferta generala, ro, fr si ru aici!

  8. #8
    Avatarul lui kleampa
    kleampa este conectat acum Ambasador
    Reputatie:
    45
    Data înscrierii
    31st May 2006
    Locaţie
    Bucuresti
    Vârstă
    32
    Posturi
    1.531
    Putere Rep
    45


    1 out of 1 members found this post helpful.

    Implicit

    o dovada buna e sa faci un faci un fisier .php care sa contina
    <?php
    phpinfo();
    ?>

    apoi il accesez in browser si o sa vezi diverse informatii legate de php (versiune, extensii etc).
    si te uiti acolo daca ai extensia mysql sau mysqli

    cu informatia asta te duci si le spui "nu e activa asta, va rog activati-o ca eu nu am acces in cpanel sa fac asta"
    Ești bun/ă la SEO? Vezi joburi disponibile.

  9. #9
    Avatarul lui Rapsodia
    Rapsodia este deconectat Membru SeoPedia
    Reputatie:
    24
    Data înscrierii
    18th March 2013
    Locaţie
    Hungary + Chișinău + Câmpina
    Posturi
    2.604
    Putere Rep
    24


    Implicit

    Da, se pare ca sunt 2 versiuni de 7.4, merge cu PHP 7.4 (ea-php74) - cu 8 nu merge inca dar e ok, am rezolvat. eu nu vdeam ca-s 2, mai e si alt php 74
    Ofer servicii Social Media Marketing!. Articole contra cost Oferta generala, ro, fr si ru aici!

Informații subiect

Utilizatori care navighează în acest subiect

Momentan este/sunt 1 utilizator(i) care navighează în acest subiect. (0 membrii și 1 vizitatori)

Thread-uri Similare

  1. Hosting Versiune php
    De Vargau în forumul Hosting
    Răspunsuri: 9
    Ultimul Post: 30th October 2014, 16:54
  2. bbpress cum se configureaza si instaleaza?
    De Popa Mihai în forumul Bar, lobby...
    Răspunsuri: 1
    Ultimul Post: 30th January 2013, 13:51
  3. Cresteri de trafic In ultima perioada
    De RoManiac în forumul Google
    Răspunsuri: 3
    Ultimul Post: 7th December 2011, 09:26
  4. Ultima tehnica SEO
    De Maldinii în forumul Google
    Răspunsuri: 34
    Ultimul Post: 28th September 2011, 11:12
  5. Ultima reusita pe Google
    De florin în forumul Bar, lobby...
    Răspunsuri: 3
    Ultimul Post: 9th August 2006, 14:59

Permisiuni postare

  • Nu puteţi posta subiecte noi.
  • Nu puteţi răspunde la subiecte
  • Nu puteţi adăuga ataşamente
  • Nu puteţi modifica posturile proprii
  •